Re: [PATCH 6/9] perf util: Get rid of malloc_or_die() intrace-event-read.c
From: Arnaldo Carvalho de Melo
Date: Wed Mar 20 2013 - 09:04:31 EST
Em Tue, Mar 19, 2013 at 11:13:25PM -0400, Steven Rostedt escreveu:
> On Wed, 2013-03-20 at 12:00 +0900, Namhyung Kim wrote:
> > On Tue, 19 Mar 2013 21:55:02 -0400, Steven Rostedt wrote:
> > > On Wed, 2013-03-20 at 10:14 +0900, Namhyung Kim wrote:
> > >> On Tue, 19 Mar 2013 10:50:02 -0400, Steven Rostedt wrote:
> > >> > On Tue, 2013-03-19 at 17:53 +0900, Namhyung Kim wrote:
> > >> > I think I like the err += func() and check for err < 0, better.
> > >> Okay, I'll change them to err |= func() style if you're fine as Peter
> > >> suggested.
> > > += or |= I'm not picky ;-)
> > Ah, one thing I also care was the short-circuit logic. I think we don't
> > need to call later functions if one fails, do we?
> Yeah, good point. It still looks ugly, but it does make sense.
Yes, I dislike all this += or |=, it should be normal exception
handling, just like everywhere in the kernel codebase:
err = foo();
err = bar();
err = baz();
err = new_foo();
That way exception handling code lies at the end of the
function, i.e. in source and binary code it has a lower chance of
polluting brain and CPU caches, and we don't need to call N functions
if we'll bail out when the one of them fails.
I.e. nothing new here, just follow kernel coding style, move
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/