Re: New prototype computer problem with S3 suspend

From: Boszormenyi Zoltan
Date: Fri Jun 07 2013 - 04:14:43 EST

2013-06-07 03:17 keltezéssel, Aaron Lu írta:
On 06/07/2013 02:11 AM, Boszormenyi Zoltan wrote:

we are working on an Intel Atom-based embedded PC and I have to
make suspend-to-RAM work but I can't seem to succeed.

The symptom is that quite often, the machine resumes immediately
after pm-suspend. Sometimes more than 20 times out of 50 attempts.
Can you please file a bug about this?

I have tried 3.7.10, 3.9.4, 3.10-rc[234] and the linux-next branch from the
git:// repository.
The attached dmesg is from today's linux-pm/linux-next plus the
latest drm-fixes patchset posted by Dave Airlie.

I have tried disabling wakeup devices via /proc/acpi/wakeup and via sysfs files.
>From the dmesg, the following three devices are still armed with wakeup
capability and might be the cause:

i8042 kbd 00:03: System wakeup enabled by ACPI
PM: suspend of devices complete after 578.883 msecs
PM: late suspend of devices complete after 0.279 msecs
pcieport 0000:00:1c.1: System wakeup enabled by ACPI
ehci-pci 0000:00:1d.7: System wakeup enabled by ACPI
PM: noirq suspend of devices complete after 31.946 msecs

Anyway, please file a bug there, thanks.

For the suspend bug:

For the warnings in i915:

Best regards,
Zoltán Böszörményi

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at