Re: [PATCH v2 1/2] mce: acpi/apei: Honour Firmware First for MCAbanks listed in APEI HEST CMC
From: Borislav Petkov
Date: Thu Jun 20 2013 - 15:29:45 EST
On Fri, Jun 21, 2013 at 12:38:13AM +0530, Naveen N. Rao wrote:
> We need this bitfield to prevent enabling CMCI in future
> cmci_discover() invocations. See usage in cmci_discover() further
/* Skip banks in firmware first mode */
if (!test_bit(i, __get_cpu_var(mce_poll_banks))
> >Yeah, let's call it ...disable_poll_bank because we're disabling polling
> >for those banks. And yes, we poll for errors for which no MCE exception
> >is generated and those happen to be corrected but still...
> We actually also disable CMCI here. So, in essence, we are disabling
> these banks for all sorts of direct corrected error reporting. I
> thought of naming this disable_ce_on_bank() or disable_ce_bank(),
> but felt that the mce_ prefix would be good to have. If that isn't
> necessary, I can rename this to disable_ce_on_bank() which sounds
> more accurate to me. Is that ok?
No, mce_disable_bank() removes the respective bank from the polling
bitfield and cmci_disable_bank() actually disables CMCI which is
Intel-only. So leave it at mce_disable_bank and that should be fine.
Sent from a fat crate under my desk. Formatting is fine.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/