Re: [PATCH] ACPI / scan: Always call acpi_bus_scan() for bus checknotifications

From: Toshi Kani
Date: Thu Jul 11 2013 - 12:15:52 EST


On Thu, 2013-07-11 at 02:39 +0200, Rafael J. Wysocki wrote:
> On Wednesday, July 10, 2013 05:48:26 PM Toshi Kani wrote:
> > On Thu, 2013-07-11 at 00:45 +0200, Rafael J. Wysocki wrote:
> > > On Wednesday, July 10, 2013 02:11:05 AM Rafael J. Wysocki wrote:
> > > > On Tuesday, July 09, 2013 01:32:42 PM Toshi Kani wrote:
> > > > > On Mon, 2013-07-08 at 02:10 +0200, Rafael J. Wysocki wrote:
> > > > > > From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
> > > > > >
> > > > > > An ACPI_NOTIFY_BUS_CHECK notification means that we should scan the
> > > > > > entire namespace starting from the given handle even if the device
> > > > > > represented by that handle is present (other devices below it may
> > > > > > just have been added).
> > > > > >
> > > > > > For this reason, modify acpi_scan_bus_device_check() to always run
> > > > > > acpi_bus_scan() if the notification being handled is of type
> > > > > > ACPI_NOTIFY_BUS_CHECK.
> > > > > >
> > > > > > Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
> > > > > > Cc: 3.10+ <stable@xxxxxxxxxxxxxxx>
> > > > >
> > > > > Acked-by: Toshi Kani <toshi.kani@xxxxxx>
> > > > >
> > > > > But, I think we need the additional patch below.
> > > >
> > > > Yes, I think you're right.
> > >
> > > That said I'd prefer to put the check into acpi_bus_device_attach() like in
> > > the appended patch.
> >
> > That's fine by me.
> >
> > Acked-by: Toshi Kani <toshi.kani@xxxxxx>
> >
> > Just a minor point, though. Isn't it a bit inconsistent with
> > device_attach(), which checks dev->driver inside the function?
>
> Well, device_attach() may be called from different places while this is
> the only place where acpi_scan_attach_handler() is called.
>
> The check in acpi_bus_device_attach() is easier to follow to me, because
> it clearly means "we don't need to do anything more if there's a handler",
> while the check in acpi_scan_attach_handler() makes you wonder "why do we
> need to return 1 in that case?" and then you need to go to the caller and
> look at the check of the return value to see "ah, because we don't want
> that device_attach() to be called then!".

Sounds good to me.

Thanks,
-Toshi


>
> > That said, I am OK with either way.
>
> Cool. :-)
>
> Thanks,
> Rafael
>
>
> > > ---
> > > From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
> > > Subject: ACPI / scan: Do not try to attach scan handlers to devices having them
> > >
> > > In acpi_bus_device_attach(), if there is an ACPI device object
> > > for the given handle and that device object has a scan handler
> > > attached to it already, there's nothing more to do for that handle
> > > and the function should just return success immediately. Make
> > > that happen.
> > >
> > > Reported-by: Toshi Kani <toshi.kani@xxxxxx>
> > > Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
> > > ---
> > > drivers/acpi/scan.c | 3 +++
> > > 1 file changed, 3 insertions(+)
> > >
> > > Index: linux-pm/drivers/acpi/scan.c
> > > ===================================================================
> > > --- linux-pm.orig/drivers/acpi/scan.c
> > > +++ linux-pm/drivers/acpi/scan.c
> > > @@ -1984,6 +1984,9 @@ static acpi_status acpi_bus_device_attac
> > > if (acpi_bus_get_device(handle, &device))
> > > return AE_CTRL_DEPTH;
> > >
> > > + if (device->handler)
> > > + return AE_OK;
> > > +
> > > ret = acpi_scan_attach_handler(device);
> > > if (ret)
> > > return ret > 0 ? AE_OK : AE_CTRL_DEPTH;
> > >
> > > --
> > > To unsubscribe from this list: send the line "unsubscribe linux-acpi" in
> > > the body of a message to majordomo@xxxxxxxxxxxxxxx
> > > More majordomo info at http://vger.kernel.org/majordomo-info.html
> >
> >
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-acpi" in
> > the body of a message to majordomo@xxxxxxxxxxxxxxx
> > More majordomo info at http://vger.kernel.org/majordomo-info.html


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/