Re: [PATCH v2 2/2] tracing: Shrink the size of struct ftrace_event_field

From: Li Zefan
Date: Sun Jul 28 2013 - 22:12:10 EST


>>> static int __trace_define_field(struct list_head *head, const char *type,
>>> const char *name, int offset, int size,
>>> int is_signed, int filter_type)
>>> @@ -120,13 +123,16 @@ static int __trace_define_field(struct list_head *head, const char *type,
>>> field->type = type;
>>>
>>> if (filter_type == FILTER_OTHER)
>>> - field->filter_type = filter_assign_type(type);
>>> - else
>>> - field->filter_type = filter_type;
>>> + filter_type = filter_assign_type(type);
>>>
>>> + field->filter_type = filter_type;
>>> field->offset = offset;
>>> field->size = size;
>>> - field->is_signed = is_signed;
>>> + field->is_signed = !!is_signed;
>>> +
>>> + VERIFY_SIZE(filter_type);
>>> + VERIFY_SIZE(offset);
>>> + VERIFY_SIZE(size);
>
> Isn't this wrap-a-macro-with-another-more-obscure-macro not a bit too
> much?
>
> I mean,
> WARN_ON(filter_type > field->filter_type)
>
> is much more readable than VERIFY_SIZE IMO.
>

Oh, right. Using macro is a bit excessive here.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/