Re: [PATCH] OPP: Export opp_add()

From: Randy Dunlap
Date: Tue Aug 06 2013 - 08:53:47 EST


On 08/03/2013 02:25 AM, Viresh Kumar wrote:
Export opp_add() so that modules can use it.

Signed-off-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
---
drivers/base/power/opp.c | 1 +
1 file changed, 1 insertion(+)

diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c
index c8ec186..ef89897 100644
--- a/drivers/base/power/opp.c
+++ b/drivers/base/power/opp.c
@@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt)
srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp);
return 0;
}
+EXPORT_SYMBOL_GPL(opp_add);

Could it be renamed to pm_opp_add() or power_opp_add() ?
The name is a bit too unspecific IMO.


/**
* opp_set_availability() - helper to set the availability of an opp



--
~Randy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/