Re: [PATCH part2 3/4] acpi: Remove "continue" in macroINVALID_TABLE().

From: Joe Perches
Date: Thu Aug 08 2013 - 10:10:01 EST


On Thu, 2013-08-08 at 20:18 +0800, Tang Chen wrote:
> Hi Joe,

Hello Tang.

> On 08/08/2013 01:27 PM, Joe Perches wrote:
> > On Thu, 2013-08-08 at 13:03 +0800, Tang Chen wrote:
> >
> >> Change it to the style like other macros:
> >>
> >> #define INVALID_TABLE(x, path, name) \
> >> do { pr_err("ACPI OVERRIDE: " x " [%s%s]\n", path, name); } while (0)
> >
> > Single statement macros do _not_ need to use
> > "do { foo(); } while (0)"
> > and should be written as
> > "foo()"
>
> OK, will remove the do {} while (0).
>
> But I think we'd better keep the macro, or rename it to something
> more meaningful. At least we can use it to avoid adding "ACPI OVERRIDE:"
> prefix every time. Maybe this is why it is defined.

No, it's just silly.

If you really think that the #define is better, use
something like HW_ERR does and embed that #define
in the pr_err.

#define ACPI_OVERRIDE "ACPI OVERRIDE: "

pr_err(ACPI_OVERRIDE "Table smaller than ACPI header [%s%s]\n",
cpio_path, file.name);

It's only used a few times by a single file so
I think it's unnecessary.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/