Re: [PATCH] cgroup: change cgroup_from_id() to css_from_id()

From: Tejun Heo
Date: Fri Aug 16 2013 - 13:07:12 EST


Hello, Li.

On Fri, Aug 16, 2013 at 03:05:16PM +0800, Li Zefan wrote:
> +/**
> + * css_from_id - lookup css by id
> + * @ss: cgroup subsys to be looked into
> + * @id: the cgroup id
> + *
> + * Returns the css if there's valid one with @id, otherwise returns NULL.
> + * Should be called under rcu_read_lock().
> + */
> +struct cgroup_subsys_state *css_from_id(struct cgroup_subsys *ss, int id)

Can we please do css_from_id(int id, struct cgroup_subsys *ss)
instead?

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/