Re: [PATCH 2/5] arm: LLVMLinux: use current_stack_pointer for percpu

From: Nicolas Pitre
Date: Sat Sep 07 2013 - 01:12:13 EST


On Fri, 6 Sep 2013, behanw@xxxxxxxxxxxxxxxxxx wrote:

> From: Behan Webster <behanw@xxxxxxxxxxxxxxxxxx>
>
> The existing code uses named registers to get the value of the stack pointer.
> The new current_stack_pointer macro is more readable and allows for a central
> portable implementation of how to get the stack pointer with ASM. This change
> supports being able to compile the kernel with both gcc and Clang.
>
> Signed-off-by: Mark Charlebois <charlebm@xxxxxxxxx>
> Signed-off-by: Behan Webster <behanw@xxxxxxxxxxxxxxxxxx>
> Reviewed-by: Jan-Simon MÃller <dl9pf@xxxxxx>
> ---
> arch/arm/include/asm/percpu.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/include/asm/percpu.h b/arch/arm/include/asm/percpu.h
> index 209e650..629a975 100644
> --- a/arch/arm/include/asm/percpu.h
> +++ b/arch/arm/include/asm/percpu.h
> @@ -30,14 +30,14 @@ static inline void set_my_cpu_offset(unsigned long off)
> static inline unsigned long __my_cpu_offset(void)
> {
> unsigned long off;
> - register unsigned long *sp asm ("sp");
> + unsigned long sp = current_stack_pointer;
>
> /*
> * Read TPIDRPRW.
> * We want to allow caching the value, so avoid using volatile and
> * instead use a fake stack read to hazard against barrier().
> */
> - asm("mrc p15, 0, %0, c13, c0, 4" : "=r" (off) : "Q" (*sp));
> + asm("mrc p15, 0, %0, c13, c0, 4" : "=r" (off) : "Q" (sp));

This change doesn't look to be equivalent. Previously the *sp implied a
memory location which doesn't appear to be the case anymore.

this sp trickery was introduced in commit 509eb76ebf97 to solve bad code
generation (the commit log has the details). It would be good if Will
Deacon could confirm that his test case still works fine with your
change.


Nicolas