Re: [PATCH 4/9] of/irq: Introduce of_irq_get()

From: Rob Herring
Date: Mon Sep 16 2013 - 17:25:19 EST


On 09/16/2013 03:32 AM, Thierry Reding wrote:
> This is a version of irq_of_parse_and_map() that propagates the precise
> error code instead of returning 0 for all errors. It will be used in
> subsequent patches to allow further propagation of error codes.
>
> To avoid code duplication, implement irq_of_parse_and_map() as a wrapper
> around the new of_irq_get().

*_get typically also implies some reference counting which I don't
believe this does. I don't think having 2 functions with completely
different names doing the same thing with only a different calling
convention is good either. So I would keep the old name and the names
aligned.

> Signed-off-by: Thierry Reding <treding@xxxxxxxxxx>
> ---
> drivers/of/irq.c | 21 +++++++++++++++++----
> include/linux/of_irq.h | 3 +++
> 2 files changed, 20 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/of/irq.c b/drivers/of/irq.c
> index 5f44388..8225289 100644
> --- a/drivers/of/irq.c
> +++ b/drivers/of/irq.c
> @@ -26,6 +26,20 @@
> #include <linux/string.h>
> #include <linux/slab.h>
>
> +int of_irq_get(struct device_node *dev, unsigned int index, unsigned int *virqp)
> +{
> + struct of_irq oirq;
> + int ret;
> +
> + ret = of_irq_map_one(dev, index, &oirq);
> + if (ret)
> + return ret;
> +
> + return __irq_create_of_mapping(oirq.controller, oirq.specifier,
> + oirq.size, virqp);
> +}
> +EXPORT_SYMBOL_GPL(of_irq_get);
> +
> /**
> * irq_of_parse_and_map - Parse and map an interrupt into linux virq space
> * @dev: Device node of the device whose interrupt is to be mapped
> @@ -36,13 +50,12 @@
> */
> unsigned int irq_of_parse_and_map(struct device_node *dev, int index)
> {
> - struct of_irq oirq;
> + unsigned int virq;
>
> - if (of_irq_map_one(dev, index, &oirq))
> + if (of_irq_get(dev, index, &virq))
> return 0;
>
> - return irq_create_of_mapping(oirq.controller, oirq.specifier,
> - oirq.size);
> + return virq;

This can be an inline and written more concisely:

{
unsigned int virq;
return (of_irq_get(dev, index, &virq) < 0) ? 0 : virq;
}

Rob


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/