[GIT PULL] extcon next for 3.13

From: Chanwoo Choi
Date: Thu Sep 26 2013 - 21:28:46 EST


Hi Greg,

This is extcon-next pull request for 3.13. I add detailed description of this
pull request on below. Please pull extcon with following updates.

Best Regards,
Chanwoo Choi

The following changes since commit 4a10c2ac2f368583138b774ca41fac4207911983:

Linux 3.12-rc2 (2013-09-23 15:41:09 -0700)

are available in the git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-3.13

for you to fetch changes up to 42d7d7539a7bcf1d493b989465283c464f4a0525:

extcon: Simplify extcon_dev_register() prototype by removing unnecessary parameter (2013-09-27 09:37:01 +0900)

----------------------------------------------------------------
Update extcon for 3.13

This patchset modify extcon core to remove unnecessary allocation sequence for
'dev' instance and change extcon_dev_register() interface. extcon-gpio use
gpiolib API to get debounce time and include small fix of extcon core/device
driver.

Detailed description for patchset:
1. Modify extcon core driver
- The extcon-gpio driver use gpio_set_debounce() API provided from gpiolib
if gpio driver for SoC support gpio_set_debounce() function and support 'gpio_
activ_low' filed to check whether gpio active state is 1(high) or 0(low).
- Change field type of 'dev' in structure extcon_dev and remove the sequence
of allocating memory of 'struct dev' on extcon_dev_register() function because
extcon device must need 'struct device.
- Change extcon_dev_register() prototype to simplify it and remove unnecessary
parameter as below:

2. Fix coding style and typo
- extcon core : Fix indentation coding style and remove unnecessary casting
- extcon-max8997 : Fix checkpatch warning
- extcon-max77693 : Fix checkpatch warning
- extcon-arizona : Fix typo of comment and modify minor issue
- extcon-palmas : Use dev_get_platdata()

3. Modify extcon-arizona driver
- Modify minor issue about micbias and comparision statement

----------------------------------------------------------------
Chanwoo Choi (3):
extcon: Fix indentation coding style to improve readability
extcon: Change field type of 'dev' in extcon_dev structure
extcon: Simplify extcon_dev_register() prototype by removing unnecessary parameter

Charles Keepax (3):
extcon: arizona: Clear trig_sts bits on all paths
extcon: arizona: Correct typo in headphone detect range transitions
extcon: arizona: Don't require micbias to be shifted in pdata

Guenter Roeck (3):
extcon: gpio: Do not unnecessarily initialize variables
extcon: gpio: Use gpio driver/chip debounce if supported
extcon: gpio: Add support for active-low presence to detect pins

Jingoo Han (2):
extcon: Remove casting the return value which is a void pointer
extcon: use dev_get_platdata()

Sachin Kamat (3):
extcon: max8997: Fix checkpatch warning
extcon: arizona: Fix a typo in a comment
extcon: max77693: Fix checkpatch warning

Documentation/extcon/porting-android-switch-class | 6 +-
drivers/extcon/extcon-adc-jack.c | 27 +++----
drivers/extcon/extcon-arizona.c | 20 ++---
drivers/extcon/extcon-class.c | 95 +++++++++++------------
drivers/extcon/extcon-gpio.c | 19 ++++-
drivers/extcon/extcon-max77693.c | 7 +-
drivers/extcon/extcon-max8997.c | 5 +-
drivers/extcon/extcon-palmas.c | 5 +-
include/linux/extcon.h | 72 ++++++++---------
include/linux/extcon/extcon-adc-jack.h | 42 +++++-----
include/linux/extcon/extcon-gpio.h | 20 +++--
11 files changed, 170 insertions(+), 148 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/