Re: [PATCH] mm/bootmem.c: remove unused 'limit' variable

From: Dave Hansen
Date: Thu Nov 21 2013 - 17:06:51 EST


On 11/21/2013 01:43 PM, Luiz Capitulino wrote:
> @@ -655,9 +655,7 @@ restart:
> void * __init __alloc_bootmem_nopanic(unsigned long size, unsigned long align,
> unsigned long goal)
> {
> - unsigned long limit = 0;
> -
> - return ___alloc_bootmem_nopanic(size, align, goal, limit);
> + return ___alloc_bootmem_nopanic(size, align, goal, 0);
> }

FWIW, I like those. The way you leave it:

return ___alloc_bootmem_nopanic(size, align, goal, 0);

the 0 is a magic number that you have to go look up the declaration of
___alloc_bootmem_nopanic() to decipher, or you have to add a comment to
it in some way.

I find it much more readable to have an 'unused' variable like that.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/