Re: [PATCH v6 7/7] jump_label: use defined macros instead of hard-codingfor better readability

From: Jason Baron
Date: Wed Dec 18 2013 - 10:55:49 EST


On 12/15/2013 06:10 AM, Jiang Liu wrote:
> On 12/14/2013 12:20 AM, Steven Rostedt wrote:
>> On Wed, 11 Dec 2013 00:03:53 +0800
>> Jiang Liu <liuj97@xxxxxxxxx> wrote:
>>
>>> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
>>> readability.
>> Looks good, just a little nit. (see below)
>>
>>> Signed-off-by: Jiang Liu <liuj97@xxxxxxxxx>
>>> ---
>>> include/linux/jump_label.h | 15 ++++++++++-----
> ...
>>> @@ -123,9 +126,11 @@ extern void static_key_slow_dec(struct static_key *key);
>>> extern void jump_label_apply_nops(struct module *mod);
>>>
>>> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
>>> - { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
>>> + { .enabled = ATOMIC_INIT(1), \
>>> + .entries = (void *)JUMP_LABEL_TYPE_TRUE_BRANCH })
>>> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
>>> - { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
>>> + { .enabled = ATOMIC_INIT(0), \
>>> + .entries = (void *)JUMP_LABEL_TYPE_FALSE_BRANCH })
>> Can we prettify the backslashes like:
>>
>> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
>> { .enabled = ATOMIC_INIT(1), \
>> .entries = (void *)JUMP_LABEL_TYPE_TRUE_BRANCH })
>> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
>> { .enabled = ATOMIC_INIT(0), \
>> .entries = (void *)JUMP_LABEL_TYPE_FALSE_BRANCH })
>>
>>
>> Other than that.
>>
>> Acked-by: Steven Rostedt <rostedt@xxxxxxxxxxx>
> Thanks Steve.
> Will make this change.

Works for me too, feel free to add:

Acked-by: Jason Baron <jbaron@xxxxxxxxxx>

Thanks,

-Jason

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/