Re: [PATCH v4 9/9] PCI/MSI: Introduce pci_auto_enable_msi*() familyhelpers

From: Alexander Gordeev
Date: Fri Dec 20 2013 - 05:26:30 EST


On Tue, Dec 17, 2013 at 05:30:02PM -0700, Bjorn Helgaas wrote:
> After this patch, we would have:
>
> pci_enable_msi() # existing (1 vector)
> pci_enable_msi_block(nvec) # existing
> pci_enable_msi_block_auto(maxvec) # existing (removed)
>
> pci_auto_enable_msi(maxvec) # new (1-maxvec)
> pci_auto_enable_msi_range(minvec, maxvec) # new
> pci_auto_enable_msi_exact(nvec) # new (nvec-nvec)
>
> pci_enable_msix(nvec) # existing
>
> pci_auto_enable_msix(maxvec) # new (1-maxvec)
> pci_auto_enable_msix_range(minvec, maxvec) # new
> pci_auto_enable_msix_exact(nvec) # new (nvec-nvec)
>
> That seems like a lot of interfaces to document and understand, especially
> since most of them are built on each other. I'd prefer just these:
>
> pci_enable_msi() # existing (1 vector)
> pci_enable_msi_range(minvec, maxvec) # new
>
> pci_enable_msix(nvec) # existing
> pci_enable_msix_range(minvec, maxvec) # new
>
> with examples in the documentation about how to call them with ranges like
> (1, maxvec), (nvec, nvec), etc. I think that will be easier than
> understanding several interfaces.

I agree pci_auto_enable_msix() and pci_auto_enable_msix_exact() are worth
sacrificing for the sake of clarity. My only concern is people will start
defining their own helpers for (1, maxvec) and (nvec, nvec) cases here and
there...

> I don't think the "auto" in the names really adds anything, does it? The
> whole point of supplying a range is that the core has the flexibility to
> choose any number of vectors within the range.

"Auto" indicates auto-retry, but I see no problem in skipping it, especially
if we deprecate or phase out the existing interfaces.

> I only see five users of pci_enable_msi_block() (nvme, ath10k, wil6210,
> ipr, vfio); we can easily convert those to use pci_enable_msi_range() and
> then remove pci_enable_msi_block().
>
> pci_enable_msi() itself can simply be pci_enable_msi_range(1, 1).
>
> There are nearly 80 callers of pci_enable_msix(), so that's a bit harder.
> Can we deprecate that somehow, and incrementally convert callers to use
> pci_enable_msix_range() instead? Maybe you're already planning that; I
> know you dropped some driver patches from the series for now, and I didn't
> look to see exactly what they did.

Right, the plan is first to introduce pci_auto_* (or whatever) family into
the tree and then gradually convert all drivers to the new interfaces.

> It would be good if pci_enable_msix() could be implemented in terms of
> pci_enable_msix_range(nvec, nvec), with a little extra glue to handle the
> positive return values.

[...]

> I think it would be better to make pci_enable_msix_range() the fundamental
> implementation, with pci_enable_msix() built on top of it. That way we
> could deprecate and eventually remove pci_enable_msix() and its tri-state
> return values.

We can reuse pci_enable_msix() name, but not before all drivers converted.

But considering the other thread you want to have only pci_enable_msi_range()
and pci_enable_msix_range() interfaces - am I getting it right?

--
Regards,
Alexander Gordeev
agordeev@xxxxxxxxxx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/