Re: [PATCH] x86, apic: clean up handling of boot_cpu_physical_apicidin boot process

From: David Rientjes
Date: Sat Jan 25 2014 - 23:03:12 EST


On Thu, 16 Jan 2014, HATAYAMA Daisuke wrote:

> Hello,
>
> This patch deals with the issue of handling boot_cpu_physical_apicid
> in boot process I avoided in disable_cpu_apicid patch because I
> cannot guess how long it needs to take for the review of this fix.
>
> This patch is made on top of today's x86/apic branch of tip tree.
> Its commit hash is 5b4d1dbc24bb6fd7179ada0f47be34e27e64decb
>

This breaks with SGI 320/540:

arch/x86/platform/visws/visws_quirks.c: In function ‘MP_processor_info’:
arch/x86/platform/visws/visws_quirks.c:169:3: error: ‘bios_cpu_physical_apicid’ undeclared (first use in this function)
arch/x86/platform/visws/visws_quirks.c:169:3: note: each undeclared identifier is reported only once for each function it appears in

It makes it pretty apparent that you want a different name for the new
variable, bios_bsp_physical_apicid is just too close to
boot_cpu_physical_apicid that even the author of the patch missed a
conversion.

(It's also really sad that we can't make it __initdata since it's only
valid at boot because of the hotplug stuff.)