Re: [PATCH 20/34] myri10ge: Use pci_enable_msix_range()

From: Hyong-Youb Kim
Date: Sat Feb 01 2014 - 09:28:26 EST



On 2/1/2014 4:24 AM, Sergei Shtylyov wrote:
Hello.

On 01/31/2014 06:08 PM, Alexander Gordeev wrote:

[...]
+ if (status < 0)
+ goto disable_msix;

Hm, if enabling MSI failed, we don't need to disable it, right? So,
perhaps the label should be renamed?


The code following disable_msix does not call pci_disable_msix(). It frees the allocated vector buffer and loads the firmware that uses a single interrupt vector. So, it is "disable" in the sense that the driver is not going to use MSI-X vectors. I agree that naming could be better.

disable_msix:
if (mgp->msix_vectors != NULL) {
kfree(mgp->msix_vectors);
mgp->msix_vectors = NULL;
}

abort_with_fw:
mgp->num_slices = 1;
set_fw_name(mgp, old_fw, old_allocated);
myri10ge_load_firmware(mgp, 0);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/