Re: [PATCH 1/2] ACPI / processor: Replace hard-coded "ACPI0007" with ACPI_PROCESSOR_DEVICE_HID

From: Rafael J. Wysocki
Date: Sat Feb 08 2014 - 09:49:01 EST


On Saturday, February 08, 2014 08:46:25 PM Hanjun Guo wrote:
> Replace "ACPI0007" with ACPI_PROCESSOR_DEVICE_HID to improve code
> readability.
>
> Signed-off-by: Hanjun Guo <hanjun.guo@xxxxxxxxxx>
> ---
> drivers/acpi/processor_core.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/acpi/processor_core.c b/drivers/acpi/processor_core.c
> index a4eea9a..849cfd6 100644
> --- a/drivers/acpi/processor_core.c
> +++ b/drivers/acpi/processor_core.c
> @@ -390,5 +390,6 @@ void __init acpi_early_processor_set_pdc(void)
> acpi_walk_namespace(ACPI_TYPE_PROCESSOR, ACPI_ROOT_OBJECT,
> ACPI_UINT32_MAX,
> early_init_pdc, NULL, NULL, NULL);
> - acpi_get_devices("ACPI0007", early_init_pdc, NULL, NULL);
> + acpi_get_devices(ACPI_PROCESSOR_DEVICE_HID,
> + early_init_pdc, NULL, NULL);

Please don't break this line (I know it will exceed 80 characters).

> }
>

--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/