Re: [alsa-devel] [PATCH 04/15] ASoC: wm5100: Update locking around use of DAPM pin API

From: Charles Keepax
Date: Tue Feb 18 2014 - 04:24:40 EST


On Tue, Feb 18, 2014 at 09:47:29AM +0900, Mark Brown wrote:
> On Mon, Feb 17, 2014 at 04:51:32PM +0000, Charles Keepax wrote:
>
> > + snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "CP2");
> > + snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "SYSCLK");
> > +
> > + mutex_unlock(&codec->dapm.card->dapm_mutex);
> > +
> > snd_soc_dapm_sync(&codec->dapm);
>
> With all these patches it seems weird that we have to drop the lock to
> do the sync which will immediately retake it. It's not broken but it
> looks off - it would be better to have a version of _sync() that we can
> call within the lock.

No problem to add a version of sync that can be called from
within the lock, should help out with Dimtry's comments as well.

>
> Regarding the naming issue that Lars mentioned I think the current
> operations are probably fine but calling them _unlocked() meaning they
> don't do any locking (as distinct from the existing _locked() which take
> locks) might be OK.

Yeah that would be good, since my original aim here was to avoid
updating every single usage of these functions.

Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/