Re: [PATCH 03/10] workqueue: async worker destruction

From: Tejun Heo
Date: Mon May 05 2014 - 11:02:26 EST


On Sun, Apr 27, 2014 at 12:08:58PM +0800, Lai Jiangshan wrote:
> /**
> + * worker_unbind_pool() - unbind the worker from the pool
> + * @worker: worker which is bound to its pool
> + *
> + * Undo the pool-binding which had been done in create_worker()
> + */
> +static void worker_unbind_pool(struct worker *worker)

worker_unbind_from_pool() would be a better name but I don't think
using bind/unbind for this purpose is a good idea. We already use
that pair of verbs for workers/pools being bound and unbound to CPUs.
I don't think we want to overload the terms for this purpose. It gets
pretty confusing. How about something like worker_detach_from_pool()
and later worker_attach_to_pool()?

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/