Re: [RFC][PATCH 1/3] PM / sleep: Flag to speed up suspend-resume of runtime-suspended devices

From: Alan Stern
Date: Thu May 08 2014 - 17:20:50 EST


On Thu, 8 May 2014, Rafael J. Wysocki wrote:

> > > Wait a minute. Following ->runtime_suspend(), you are going to call
> > > ->suspend() and then ->runtime_resume()? That doesn't seem like what
> > > you really want; a ->suspend() call should always have a matching
> > > ->resume().
> >
> > Yes, it should, but I didn't see any other way to do that.
>
> Actually, that's kind of easy to resolve. :-)
>
> When ->suspend() leaves power.leave_runtime_suspended set, the PM core can
> simply skip the early/late and noirq callbacks and then call ->resume()
> that will be responsible for using whatever is necessary to resume the
> device.
>
> And perhaps the flag should be called something different then, like
> direct_resume (meaning go directly for ->resume() without executing
> the intermediate callbacks)?

In light of what I wrote earlier, it should be okay for the ->prepare()
callback to be responsible for setting leave_runtime_suspended. Then
there will be no need to call either ->suspend() or ->resume().

Alan Stern

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/