Re: [PATCH v3 2/4] DMA-API: Change dma_declare_coherent_memory() CPU address to phys_addr_t

From: Greg Kroah-Hartman
Date: Thu May 08 2014 - 22:50:35 EST


On Thu, May 08, 2014 at 02:49:00PM -0600, Bjorn Helgaas wrote:
> dma_declare_coherent_memory() takes two addresses for a region of memory: a
> "bus_addr" and a "device_addr". I think the intent is that "bus_addr" is
> the physical address a *CPU* would use to access the region, and
> "device_addr" is the bus address the *device* would use to address the
> region.
>
> Rename "bus_addr" to "phys_addr" and change its type to phys_addr_t.
> Most callers already supply a phys_addr_t for this argument. The others
> supply a 32-bit integer (a constant, unsigned int, or __u32) and need no
> change.
>
> Use "unsigned long", not phys_addr_t, to hold PFNs.
>
> No functional change (this could theoretically fix a truncation in a config
> with 32-bit dma_addr_t and 64-bit phys_addr_t, but I don't think there are
> any such cases involving this code).
>
> Signed-off-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>
> Acked-by: Arnd Bergmann <arnd@xxxxxxxx>

Acked-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/