Re: [PATCH 5/5] usb: gadget: net2280: Use pr_* function

From: Joe Perches
Date: Mon May 19 2014 - 16:30:02 EST


On Mon, 2014-05-19 at 16:17 -0400, Alan Stern wrote:
> On Mon, 19 May 2014, Ricardo Ribalda Delgado wrote:
> > I really think that setting/unsetting DEBUG and VERBOSE is not a good
> > idea, and the generic functions are there to be used.
> You could change the definitions of DEBUG and VDEBUG to make them use
> the generic functions.
> > What do you think that makes it more difficult to read? The GETDEV macro?

Maybe add ep_<level> helper macros and remove xprint

#define ep_err(ep, fmt, ...) \
dev_err(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_warn(ep, fmt, ...) \
dev_warn(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_info(ep, fmt, ...) \
dev_info(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_dbg(ep, fmt, ...) \
dev_dbg(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_vdbg(ep, fmt, ...) \
dev_vdbg(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)

but even that conversion isn't straightforward.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/