Re: [PATCH V3 1/4] cpufreq: handle calls to ->target_index() in separate routine

From: Doug Anderson
Date: Tue May 20 2014 - 12:44:25 EST


Viresh,

On Fri, May 16, 2014 at 9:51 PM, Viresh Kumar <viresh.kumar@xxxxxxxxxx> wrote:
> Handling calls to ->target_index() has got complex over time and might become
> more complex. So, its better to take target_index() bits out in another routine
> __target_index() for better code readability. Shouldn't have any functional
> impact.
>
> Tested-by: Stephen Warren <swarren@xxxxxxxxxx>
> Signed-off-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> ---
> drivers/cpufreq/cpufreq.c | 56 ++++++++++++++++++++++++++++-------------------
> 1 file changed, 33 insertions(+), 23 deletions(-)
>
> diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c
> index a05c921..9bf12a2 100644
> --- a/drivers/cpufreq/cpufreq.c
> +++ b/drivers/cpufreq/cpufreq.c
> @@ -1816,12 +1816,43 @@ EXPORT_SYMBOL(cpufreq_unregister_notifier);
> * GOVERNORS *
> *********************************************************************/
>
> +static int __target_index(struct cpufreq_policy *policy,
> + struct cpufreq_frequency_table *freq_table, int index)
> +{
> + struct cpufreq_freqs freqs;
> + int retval = -EINVAL;
> + bool notify;
> +
> + notify = !(cpufreq_driver->flags & CPUFREQ_ASYNC_NOTIFICATION);
> +
> + if (notify) {
> + freqs.old = policy->cur;
> + freqs.new = freq_table[index].frequency;
> + freqs.flags = 0;
> +
> + pr_debug("%s: cpu: %d, oldfreq: %u, new freq: %u\n",
> + __func__, policy->cpu, freqs.old, freqs.new);
> +
> + cpufreq_freq_transition_begin(policy, &freqs);
> + }
> +
> + retval = cpufreq_driver->target_index(policy, index);
> + if (retval)
> + pr_err("%s: Failed to change cpu frequency: %d\n",
> + __func__, retval);
> +
> + if (notify)
> + cpufreq_freq_transition_end(policy, &freqs, retval);
> +
> + return retval;
> +}
> +
> int __cpufreq_driver_target(struct cpufreq_policy *policy,
> unsigned int target_freq,
> unsigned int relation)
> {
> - int retval = -EINVAL;
> unsigned int old_target_freq = target_freq;
> + int retval = -EINVAL;

I'm not sure that this shuffling was really necessary, but I guess it
doesn't hurt. ...and I guess a CL that's shuffling code anyway is the
place to put it...

Reviewed-by: Doug Anderson <dianders@xxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/