[PATCHv6 0/3] Common Mailbox Framework

From: Jassi Brar
Date: Mon Jun 02 2014 - 14:24:44 EST


Hello,
Here is the next revision of Mailbox framwork.

Changes since v5:
o Use standard error types instead of special type mbox_result.
o Constify client struct in request_channel
o Use reinit_completion instead of init_completion every time.
o Improve commentary in bindings and code.

Changes since v4:
o Common DT binding for Controller and Client drivers
As a result, discard string based channel matching
o Provide for an atomic 'peek' api, that a client could
call to trigger the controller driver push data upwards.
o OMAP and Highbank conversion to new api is left out, which
can be converted later by the developers.

Changes since v3:
o Change name of symbols from ipc to mbox
o Return real types instead of void *
o Align structures
o Change some symbol names
rxcb -> rx_callback
txcb -> tx_done
o Added kernel-doc for exported API
o Dropped the cl_id and use clients pointer for callbacks.
o Fixed locking of channel pool
o Return negative error code for unsuccessful ipc_send_message()
o Module referencing during mailbox assignment to a client.
o Made error code symbols specific to mailbox.

Thanks
Jassi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/