Kernel for olpc-1.75

From: Pavel Machek
Date: Sat Jun 07 2014 - 18:54:13 EST


I broke installation on olpc-1.75, and I guess its time for it to
start running self-compiled kernel. (It still boots if I hold right
game key, but I can no longer control backlight. It does not boot at
all by default.)

AFAICT, olpc.fth and zImage in the boot/ directory of USB disk should
do the trick.

Unfortunately, 3.0 based kernels no longer compile with current tools,
so I tried this version (3.6 based).

commit 2a873e0e3681412ccc82a646630ffaf119d36af0
Author: Chris Ball <cjb@xxxxxxxxxx>
Date: Wed Aug 22 18:51:58 2012 -0400

Revert "ARM: mmp: Send decompress and debug output to UART3
instead of UART2

This reverts commit 8fb8e2ccffd5387c4a5e4e5294270fa61716eb51.

Unfortunately, no output at all with

I tried replacing all =m's in .config with =y, but still no output.

Is there more recent kernel to work with? Is 2a87... somehow buggy?
Did I miss some critical step? Will recent mainline run on olpc

(cesky, pictures)
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at