Re: [PATCH] Revert lockdep check in raw_seqcount_begin

From: John Stultz
Date: Wed Jun 11 2014 - 14:39:32 EST


On Thu, Jun 5, 2014 at 8:31 AM, Trond Myklebust
<trond.myklebust@xxxxxxxxxxxxxxx> wrote:
> This commit reverts the addition of lockdep checking to raw_seqcount_begin
> for the following reasons:
>
> 1) It violates the naming convention that raw_* functions should not
> do lockdep checks (a convention that is also followed by the other
> raw_*_seqcount_begin functions).
> 2) raw_seqcount_begin does not spin, so it can only be part of an ABBA
> deadlock in very special circumstances (for instance if a lock
> is held across the entire raw_seqcount_begin()+read_seqcount_retry()
> loop while also being taken inside the write_seqcount protected area).
> 3) It is causing false positives with some existing callers, and there
> is no non-lockdep alternative for those callers to use.
>
> None of the three existing callers (__d_lookup_rcu, netdev_get_name, and
> the NFS state code) appear to use the function in a manner that is ABBA
> deadlock prone.
>
> Fixes: 1ca7d67cf5d5: seqcount: Add lockdep functionality to seqcount/seqlock
> Cc: John Stultz <john.stultz@xxxxxxxxxx>
> Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> Cc: Ingo Molnar <mingo@xxxxxxxxxx>
> Cc: "David S. Miller" <davem@xxxxxxxxxxxxx>
> Cc: Al Viro <viro@xxxxxxxxxxxxxxxxxx>
> Link: http://lkml.kernel.org/r/CAHQdGtRR6SvEhXiqWo24hoUh9AU9cL82Z8Z-d8-7u951F_d+5g@xxxxxxxxxxxxxx
> Signed-off-by: Trond Myklebust <trond.myklebust@xxxxxxxxxxxxxxx>
> ---
> include/linux/seqlock.h | 2 --
> 1 file changed, 2 deletions(-)
>
> diff --git a/include/linux/seqlock.h b/include/linux/seqlock.h
> index 535f158977b9..8cf350325dc6 100644
> --- a/include/linux/seqlock.h
> +++ b/include/linux/seqlock.h
> @@ -164,8 +164,6 @@ static inline unsigned read_seqcount_begin(const seqcount_t *s)
> static inline unsigned raw_seqcount_begin(const seqcount_t *s)
> {
> unsigned ret = ACCESS_ONCE(s->sequence);
> -
> - seqcount_lockdep_reader_access(s);
> smp_rmb();
> return ret & ~1;
> }

Just back from vacation, sorry for the slow response. Thanks for
submitting this! Also sorry for my confusion mixing
raw_seqcount_begin() and raw_seqlock_begin() in our earlier discussion
(I blame the hectic vacation prep ;).

Acked-by: John Stultz <john.stultz@xxxxxxxxxx>

thanks
-john
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/