Re: [PATCH 1/1] block/bio.c: use GFP_NOFS

From: Hugh Dickins
Date: Sun Jun 15 2014 - 20:29:56 EST


On Sat, 14 Jun 2014, Fabian Frederick wrote:

> Use GFP_NOFS instead of its definition.
>
> Cc: Jens Axboe <axboe@xxxxxxxxx>
> Signed-off-by: Fabian Frederick <fabf@xxxxxxxxx>
> ---
> block/bio.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/block/bio.c b/block/bio.c
> index 8c2e55e..ec5d172 100644
> --- a/block/bio.c
> +++ b/block/bio.c
> @@ -211,7 +211,7 @@ fallback:
> bvl = mempool_alloc(pool, gfp_mask);
> } else {
> struct biovec_slab *bvs = bvec_slabs + *idx;
> - gfp_t __gfp_mask = gfp_mask & ~(__GFP_WAIT | __GFP_IO);
> + gfp_t __gfp_mask = gfp_mask & ~GFP_NOFS;
>
> /*
> * Make this allocation restricted and don't dump info on
> --
> 1.8.4.5

Please no. The original was fine, this just makes it harder to read.

GFP_NOFS is a useful and widely used combination of flags for passing
down to the page allocator; but it is merely obscure when used as you
have for masking bits off.

(But I confess to hypocrisy in finding "& ~GFP_KERNEL" useful myself
in the past somewhere.)

Hugh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/