Re: [PATCH V4 02/16] perf, core: introduce pmu context switch callback

From: Yan, Zheng
Date: Thu Jul 03 2014 - 01:47:22 EST


On 07/02/2014 06:12 PM, Peter Zijlstra wrote:
> On Mon, Jun 30, 2014 at 04:50:39PM +0800, Yan, Zheng wrote:
>> @@ -2362,6 +2363,58 @@ unlock:
>> }
>> }
>>
>> +void perf_sched_cb_disable(struct pmu *pmu)
>> +{
>> + __get_cpu_var(perf_sched_cb_usages)--;
>> +}
>> +
>> +void perf_sched_cb_enable(struct pmu *pmu)
>> +{
>> + __get_cpu_var(perf_sched_cb_usages)++;
>> +}
>
> Those should not be called {dis,en}able, they don't as such do that.

I can't think up a better name. what should they be called?

Regards
Yan, Zheng

> Also we have: this_cpu_{inc,dec} for this.
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/