Re: [PATCH 0/25] Replace DEFINE_PCI_DEVICE_TABLE macro use
From: David Miller
Date: Mon Jul 21 2014 - 00:18:26 EST
From: Benoit Taine <benoit.taine@xxxxxxx>
Date: Fri, 18 Jul 2014 17:26:47 +0200
> We should prefer `const struct pci_device_id` over
> `DEFINE_PCI_DEVICE_TABLE` to meet kernel coding style guidelines.
> This issue was reported by checkpatch.
> A simplified version of the semantic patch that makes this change is as
> follows (http://coccinelle.lip6.fr/):
> // <smpl>
> identifier i;
> declarer name DEFINE_PCI_DEVICE_TABLE;
> initializer z;
> - DEFINE_PCI_DEVICE_TABLE(i)
> + const struct pci_device_id i
> = z;
> // </smpl>
> I have 103 patches ready, and will only send a few for you to judge if
> it is useful enough, and to prevent from spamming too much.
I'm fine with this wrt. the networking changes, but I don't think this should
be merged via my tree.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/