[PATCH 0/1] Replace DEFINE_PCI_DEVICE_TABLE macro use
From: Benoit Taine
Date: Fri Aug 08 2014 - 09:55:11 EST
We should prefer `const struct pci_device_id` over
`DEFINE_PCI_DEVICE_TABLE` to meet kernel coding style guidelines.
This issue was reported by checkpatch.
A simplified version of the semantic patch that makes this change is as
declarer name DEFINE_PCI_DEVICE_TABLE;
+ const struct pci_device_id i
I previously sent parts of this patch to check wether or not it was
worth sending, and Bjorn answered:
> Benoit, how about if you wait until about half-way through the merge
> window after v3.16 releases, generate an up-to-date single patch, and
> post that? Then we can try to get it in before v3.17-rc1 to minimize
> merge hassles.
So here it is, based on linux-next on 2014-08-07.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/