[BUG] perf top: -z option does not work

From: Stephane Eranian
Date: Tue Aug 12 2014 - 00:44:39 EST


My understanding is that the -z option is used to only print a profile
since the last refresh. So if I have a refresh of 5s, then it prints the profile
based on the samples accumulated over the last 5 seconds.

The Z mode used to be available interactively. Nowadays, it seems only
avail from the cmdline. But it does not work.

I run a simple test.
$ sudo perf top -z

Then for 5s I run a cycle-burning noploop program.
It shows up at the top. But when it terminates, the program still stays
at the top of the profile for a long time. This is not what I'd expect.
The noploop line should disappear in the next couple of refreshes after
the program has terminated.

I am using tip.git and seeing the problem. But it seems, it's been there for a
long time.

Any idea what's wrong?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/