[PATCH v6 0/3] usb: gadget: f_fs: userspace API fixes and improvements

From: Robert Baldyga
Date: Mon Aug 25 2014 - 05:16:55 EST

This patchset contains changes in FunctionFS making it easier and
safer to use. It fixes bug in endpoint files handling code, adds new
ioctl allowing to obtain endpoint descriptor, and introduces virtual
address mapping which allows to separate endpoint address space in
function from physical endpoint addresses, and introduces new endpoint
files naming convention.


- unlock spinlock before copy_to_user() call
- remove duplicated eps_count value check
- few minor fixes

v5: https://lkml.org/lkml/2014/8/21/252
- fix typo pointed by Sergei Shtylyov

v4: https://lkml.org/lkml/2014/8/20/277
- change if() sequence into switch() statement

v3: https://lkml.org/lkml/2014/7/30/115
- move fix for the redundant ep files problem into sepatare patch
- merge user space API affecting changes into single patch
- add flag switching between old and new style API

v2: https://lkml.org/lkml/2014/7/25/296
- return proper endpont address in setup request handling
- add patch usb: gadget: f_fs: add ioctl returning ep descriptor
- add patch usb: gadget: f_fs: make numbers in ep file names the same
as ep addresses

v1: https://lkml.org/lkml/2014/7/18/1010

Robert Baldyga (3):
usb: gadget: f_fs: fix the redundant ep files problem
usb: gadget: f_fs: add ioctl returning ep descriptor
usb: gadget: f_fs: virtual endpoint address mapping

drivers/usb/gadget/function/f_fs.c | 112 +++++++++++++++++++++++++++++++-----
drivers/usb/gadget/function/u_fs.h | 4 ++
include/uapi/linux/usb/functionfs.h | 7 +++
3 files changed, 110 insertions(+), 13 deletions(-)


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/