Re: [PATCH v2] memory-hotplug: add sysfs zones_online_to attribute

From: Toshi Kani
Date: Mon Aug 25 2014 - 10:09:13 EST


On Fri, 2014-08-22 at 15:16 -0700, Andrew Morton wrote:
> On Mon, 18 Aug 2014 11:25:36 +0800 Zhang Zhen <zhenzhang.zhang@xxxxxxxxxx> wrote:
>
> > On 2014/8/16 5:37, Toshi Kani wrote:
> > > On Wed, 2014-08-13 at 12:10 +0800, Zhang Zhen wrote:
> > >> Currently memory-hotplug has two limits:
> > >> 1. If the memory block is in ZONE_NORMAL, you can change it to
> > >> ZONE_MOVABLE, but this memory block must be adjacent to ZONE_MOVABLE.
> > >> 2. If the memory block is in ZONE_MOVABLE, you can change it to
> > >> ZONE_NORMAL, but this memory block must be adjacent to ZONE_NORMAL.
> > >>
> > >> With this patch, we can easy to know a memory block can be onlined to
> > >> which zone, and don't need to know the above two limits.
> > >>
> > >> Updated the related Documentation.
> > >>
> > >> Change v1 -> v2:
> > >> - optimize the implementation following Dave Hansen's suggestion
> > >>
> > >> Signed-off-by: Zhang Zhen <zhenzhang.zhang@xxxxxxxxxx>
> > >> ---
> > >> Documentation/ABI/testing/sysfs-devices-memory | 8 ++++
> > >> Documentation/memory-hotplug.txt | 4 +-
> > >> drivers/base/memory.c | 62 ++++++++++++++++++++++++++
> > >> include/linux/memory_hotplug.h | 1 +
> > >> mm/memory_hotplug.c | 2 +-
> > >> 5 files changed, 75 insertions(+), 2 deletions(-)
> > >>
> > >> diff --git a/Documentation/ABI/testing/sysfs-devices-memory b/Documentation/ABI/testing/sysfs-devices-memory
> > >> index 7405de2..2b2a1d7 100644
> > >> --- a/Documentation/ABI/testing/sysfs-devices-memory
> > >> +++ b/Documentation/ABI/testing/sysfs-devices-memory
> > >> @@ -61,6 +61,14 @@ Users: hotplug memory remove tools
> > >> http://www.ibm.com/developerworks/wikis/display/LinuxP/powerpc-utils
> > >>
> > >>
> > >> +What: /sys/devices/system/memory/memoryX/zones_online_to
> > >
> > > I think this name is a bit confusing. How about "valid_online_types"?
> > >
> > Thanks for your suggestion.
> >
> > This patch has been added to -mm tree.
> > If most people think so, i would like to modify the interface name.
> > If not, let's leave it as it is.
>
> Yes, the name could be better. Do we actually need "online" in there?
> How about "valid_zones"?

I suggested using "online" because a user specifies a zone type during
an online operation as follows.

$ echo online_movable > /sys/devices/system/memory/memoryXXX/state

I also like "valid_zones" and it well represents what it is (and the
name is shorter :-). I am fine with this name as well.

Thanks,
-Toshi

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/