Re: [RFC 00/10] perf pollfd series

From: Arnaldo Carvalho de Melo
Date: Mon Aug 25 2014 - 11:56:31 EST

Em Mon, Aug 25, 2014 at 01:04:31PM +0200, Jiri Olsa escreveu:
> fdarray name seems too generic for this object, fdpoll looks
> more suitable.. also given that the file name is poll.[ch] ;-)

I thought about 'struct pollfds', then thought that having 'poll' in the
name of the class and in its main routine, i.e. pollfds__poll, would be
too much.

I thought of it as an extensible array of file descriptors that right
now has just poll related operations, but could have some other
operations, perhaps the associated mmaps in evlist, for instance.

I ended up using poll.[ch] because struct pollfd came from poll.h, but
yeah, that is inconsistent with poll being just one of the operations
for an extensible array of file descriptors, so it should be renamed
accordingly to 'fdarray.[ch]'.

That was my reasoning.

I'm looking at the other comments, would send a fix for what Adrian
commented but thought about an optimization, will do that after lunch,
hopefully food will prevent me from adding more bugs 8-)

> anyway, except for what I've already commented:

> Acked-by: Jiri Olsa <jolsa@xxxxxxxxxx>


- Arnaldo
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at