Re: [RFC PATCH] powerpc: Wire up three syscalls

From: Pranith Kumar
Date: Sun Aug 31 2014 - 08:52:53 EST

Hi Geert,

On Sun, Aug 31, 2014 at 4:53 AM, Geert Uytterhoeven
<geert@xxxxxxxxxxxxxx> wrote:
> Hi Pranith,
> On Sat, Aug 30, 2014 at 5:36 AM, Pranith Kumar <bobby.prani@xxxxxxxxx> wrote:
>> I see that the three syscalls seccomp, getrandom and memfd_create are not wired
>> because of which we get a warning while compilation.
>> So I wired them up in this patch. What else needs to be done? I tried the
>> memfd_test after compiling this kernel, but it is failing. What am I missing for
>> this to work? Any advice is really appreciated! :)
> Did it fail due to the (silly) "ifeq ($(ARCH),X86)" checks in
> tools/testing/selftests/memfd/Makefile?

I removed that check and compiled memfd_test.c by hand. This is the
following error which I get when I run the test:

$ ./memfd_test
memfd: CREATE
memfd: BASIC
10 != 0 = GET_SEALS(3)

This is basically when checking the seals which we already added. It
should return 10 (F_SEAL_SHRINK | F_SEAL_WRITE), instead it is returning 0.

What else needs to be done for this to properly work? I see that for
m68k, you just wired it up like in this patch. Did it work after that?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at