Re: [PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

From: Denys Vlasenko
Date: Thu Sep 04 2014 - 12:52:22 EST


On Thu, Sep 4, 2014 at 3:42 PM, Oleg Nesterov <oleg@xxxxxxxxxx> wrote:
> -#ifdef CONFIG_TRACE_IRQFLAGS
> /* put return address in eax (arg1) */
> - .macro thunk_ra name,func
> + .macro thunk_ra name, func, put_ret_addr_in_eax=0
> .globl \name
> \name:
> pushl %eax
> pushl %ecx
> pushl %edx
> +
> + .if \put_ret_addr_in_eax
> /* Place EIP in the arg1 */
> movl 3*4(%esp), %eax
> + .endif
> +
> call \func
> popl %edx
> popl %ecx
> @@ -25,6 +28,15 @@
> _ASM_NOKPROBE(\name)
> .endm
>
> - thunk_ra trace_hardirqs_on_thunk,trace_hardirqs_on_caller
> - thunk_ra trace_hardirqs_off_thunk,trace_hardirqs_off_caller
> +#ifdef CONFIG_TRACE_IRQFLAGS
> + thunk_ra trace_hardirqs_on_thunk,trace_hardirqs_on_caller,1
> + thunk_ra trace_hardirqs_off_thunk,trace_hardirqs_off_caller,1
> +#endif
> +
> +#ifdef CONFIG_PREEMPT
> + THUNK ___preempt_schedule, preempt_schedule
> +#ifdef CONFIG_CONTEXT_TRACKING
> + THUNK ___preempt_schedule_context, preempt_schedule_context
> #endif
> +#endif


I think THUNK should be thunk_ra here;
or thunk_ra should be renamed to THUNK (like it is in thunk_64.S)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/