Re: [PATCH RESEND v5 1/5] usb: host: ehci-st: Add EHCI support for ST STB devices

From: Arnd Bergmann
Date: Fri Sep 05 2014 - 13:57:42 EST


On Friday 05 September 2014 18:23:45 Peter Griffin wrote:
> +struct st_platform_priv {
> + struct clk *clks[USB_MAX_CLKS];
> + struct clk *clk48;
> + struct reset_control *rst;
> + struct reset_control *pwr;
> + struct phy *phy;
> +};

Any reason why this is in a shared header file? It looks like
duplicating the structure under two different names would
actually be shorter and keep the drivers more readable as they'd
be self-contained, even when they have the exact same structure.

Do both drivers use all fields?

Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/