Re: [PATCH v4 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea

From: Peter Chen
Date: Fri Sep 12 2014 - 05:28:47 EST


On Fri, Sep 12, 2014 at 10:21:25AM +0200, Antoine Tenart wrote:
> Peter,
>
> On Fri, Sep 12, 2014 at 01:10:33AM +0000, Peter Chen wrote:
> > > On Thu, Sep 11, 2014 at 08:54:47AM +0800, Peter Chen wrote:
> > > > On Wed, Sep 03, 2014 at 09:40:40AM +0200, Antoine Tenart wrote:
> > > > > @@ -595,23 +639,27 @@ static int ci_hdrc_probe(struct platform_device
> > > *pdev)
> > > > > return -ENODEV;
> > > > > }
> > > > >
> > > > > - if (ci->platdata->usb_phy)
> > > > > + if (ci->platdata->phy)
> > > > > + ci->phy = ci->platdata->phy;
> > > > > + else if (ci->platdata->usb_phy)
> > > > > ci->usb_phy = ci->platdata->usb_phy;
> > > > > else
> > > > > - ci->usb_phy = devm_usb_get_phy(dev, USB_PHY_TYPE_USB2);
> > > > > + ci->phy = devm_phy_get(dev, "usb-phy");
> > > > >
> > > > > - if (IS_ERR(ci->usb_phy)) {
> > > > > - ret = PTR_ERR(ci->usb_phy);
> > > > > + if (IS_ERR(ci->phy) || (ci->phy == NULL && ci->usb_phy == NULL)) {
> > > > > /*
> > > > > * if -ENXIO is returned, it means PHY layer wasn't
> > > > > * enabled, so it makes no sense to return -EPROBE_DEFER
> > > > > * in that case, since no PHY driver will ever probe.
> > > > > */
> > > > > - if (ret == -ENXIO)
> > > > > - return ret;
> > > > > + if (PTR_ERR(ci->phy) == -ENXIO)
> > > > > + return -ENXIO;
> > > > >
> > > > > - dev_err(dev, "no usb2 phy configured\n");
> > > > > - return -EPROBE_DEFER;
> > > > > + ci->usb_phy = devm_usb_get_phy(dev, USB_PHY_TYPE_USB2);
> > > > > + if (IS_ERR(ci->usb_phy)) {
> > > > > + dev_err(dev, "no usb2 phy configured\n");
> > > > > + return -EPROBE_DEFER;
> > > > > + }
> > > > > }
> > > >
> > > > Sorry, I can't accept this change, why devm_usb_get_phy(dev,
> > > > USB_PHY_TYPE_USB2) is put at error path? Since current get PHY
> > > > operation is a little complicated, we may have a dedicate function to do it,
> > > dwc3 driver is a good example.
> > >
> > > It's not the error path, it's the case when there is no PHY from the generic PHY
> > > framework available. Getting an USB PHY is a fallback solution.
> > >
> > > I agree we can move this to a dedicated function. But even if doing so, we'll
> > > have to test ci->phy first.
> > >
> > > Or do you have something else in mind?
> > >
> >
> > I still want devm_usb_get_phy(dev, USB_PHY_TYPE_USB2) to be called at the same place
> > like generic_phy, not in later error path, in error path, we only handle error.
>
> Would this fit you?
>
> if (ci->platdata->phy)
> ci->phy = ci->platdata->phy;
> else if (ci->platdata->usb_phy)
> ci->usb_phy = ci->platdata->usb_phy;
>
> if (ci->phy == NULL && ci->usb_phy == NULL) {

You should use else if here.

> ci->phy = devm_phy_get(dev, "usb-phy");
> ci->usb_phy = devm_usb_get_phy(dev, USB_PHY_TYPE_USB2);
>
> /* if both generic PHY and USB PHY layers aren't enabled */
> if (PTR_ERR(ci->phy) == -ENOSYS && PTR_ERR(ci->usb_phy) == -ENXIO)
> return -ENXIO;
>
> if (IS_ERR(ci->phy) && IS_ERR(ci->usb_phy))
> return -EPROBE_DEFER;
>
> /* if an usb_phy is available, but no phy is there */
> if (PTR_ERR(ci->phy) == -ENODEV)
> ci->phy = NULL;
if (ci->phy)
ci->usb_phy = NULL;
if (ci->usb_phy)
ci->phy = NULL;

How about above?


--
Best Regards,
Peter Chen
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/