Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

From: Peter Zijlstra
Date: Mon Sep 22 2014 - 16:07:24 EST


On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote:
> Use the much easier to read ACCESS_ONCE() which is basically the same thing as
> the cast to volatile.
>
> Please note the change in volatile cast: ACCESS_ONCE(v)->counter to
> ACCESS_ONCE(v->counter).
>
> Signed-off-by: Pranith Kumar <bobby.prani@xxxxxxxxx>
> ---
> arch/x86/include/asm/atomic.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

If you want to do something like so, then be consistent and do them all.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/