[PATCH] lib: rename TEST_MODULE to TEST_LKM

From: Valentin Rothberg
Date: Tue Sep 23 2014 - 02:58:42 EST


The "_MODULE" suffix is reserved for tristates compiled as
loadable kernel modules (LKM). The "TEST_MODULE" feature thereby
violates this convention. The feature is used to compile the
lib/test_module.c kernel module.

This patch renames the feature and its reference in a Makefile
to "TEST_LKM", which still expresses the test of a LKM.

Signed-off-by: Valentin Rothberg <valentinrothberg@xxxxxxxxx>
---
lib/Kconfig.debug | 2 +-
lib/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
index 07c2832..db91c97 100644
--- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug
@@ -1627,7 +1627,7 @@ config DMA_API_DEBUG

If unsure, say N.

-config TEST_MODULE
+config TEST_LKM
tristate "Test module loading with 'hello world' module"
default n
depends on m
diff --git a/lib/Makefile b/lib/Makefile
index d6b4bc4..382437a 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -31,7 +31,7 @@ obj-y += string_helpers.o
obj-$(CONFIG_TEST_STRING_HELPERS) += test-string_helpers.o
obj-y += kstrtox.o
obj-$(CONFIG_TEST_KSTRTOX) += test-kstrtox.o
-obj-$(CONFIG_TEST_MODULE) += test_module.o
+obj-$(CONFIG_TEST_LKM) += test_module.o
obj-$(CONFIG_TEST_USER_COPY) += test_user_copy.o
obj-$(CONFIG_TEST_BPF) += test_bpf.o
obj-$(CONFIG_TEST_FIRMWARE) += test_firmware.o
--
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/