RE: [f2fs-dev] [PATCH 1/4] f2fs: check the use of macros on block counts and addresses

From: Chao Yu
Date: Tue Sep 30 2014 - 02:20:24 EST


Hi Jaegeuk,

> -----Original Message-----
> From: Jaegeuk Kim [mailto:jaegeuk@xxxxxxxxxx]
> Sent: Friday, September 26, 2014 12:55 PM
> To: linux-kernel@xxxxxxxxxxxxxxx; linux-fsdevel@xxxxxxxxxxxxxxx;
> linux-f2fs-devel@xxxxxxxxxxxxxxxxxxxxx
> Cc: Jaegeuk Kim
> Subject: [f2fs-dev] [PATCH 1/4] f2fs: check the use of macros on block counts and addresses
>
> This patch cleans up the existing and new macros for readability.
>
> Rule is like this.
>
> ,-----------------------------------------> MAX_BLKADDR -,
> | ,------------- TOTAL_BLKS ----------------------------,
> | | |
> | ,- seg0_blkaddr ,----- sit/nat/ssa/main blkaddress |
> block | | (SEG0_BLKADDR) | | | | (e.g., MAIN_BLKADDR) |
> address 0..x................ a b c d .............................
> | |
> global seg# 0...................... m .............................
> | | |
> | `------- MAIN_SEGS -----------'
> `-------------- TOTAL_SEGS ---------------------------'
> | |
> seg# 0..........xx..................
>
> = Note =
> o GET_SEGNO_FROM_SEG0 : blk address -> global segno
> o GET_SEGNO : blk address -> segno
> o START_BLOCK : segno -> starting block address
>
> Signed-off-by: Jaegeuk Kim <jaegeuk@xxxxxxxxxx>

Looks good!

Reviewed-by: Chao Yu <chao2.yu@xxxxxxxxxxx>

I see SM_I(sbi)->segment_count in check_seg_range/check_block_count still
not be instead with TOTAL_SEGS(sbi), how about insteading these together?

Regards,
Yu

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/