Re: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in hci_disconnect()

From: Marcel Holtmann
Date: Thu Oct 23 2014 - 18:09:46 EST


Hi Fabian,

>>> use cpr for hci_cp_read_clock_offset instead of cp
>>> (already defined above).
>>>
>>> Signed-off-by: Fabian Frederick <fabf@xxxxxxxxx>
>>> ---
>>> net/bluetooth/hci_conn.c | 6 +++---
>>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>>
>>> diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
>>> index b9517bd..6151e09 100644
>>> --- a/net/bluetooth/hci_conn.c
>>> +++ b/net/bluetooth/hci_conn.c
>>> @@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
>>> */
>>> if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
>>> struct hci_dev *hdev = conn->hdev;
>>> - struct hci_cp_read_clock_offset cp;
>>> + struct hci_cp_read_clock_offset cpr;
>>>
>>> - cp.handle = cpu_to_le16(conn->handle);
>>> - hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
>>> + cpr.handle = cpu_to_le16(conn->handle);
>>> + hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);
>>
>> valid change, but I do not like cpr as variable name. We need to come up with
>> a better one. There are other places in the code where we had the same thing.
>> Please have a look there.
>
> Maybe read_cp (like commit c1f23a2bfc89 with struct hci_cp_auth_requested
> auth_cp) ?

lets use clkoff_cp unless someone comes up with a better name.

Regards

Marcel

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/