Re: [PATCH RFC 05/12] time: Convert rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys()

From: Thomas Gleixner
Date: Mon Oct 27 2014 - 18:13:45 EST


On Mon, 27 Oct 2014, Thomas Gleixner wrote:

> On Mon, 27 Oct 2014, pang.xunlei wrote:
> > The kernel uses 32-bit signed value(time_t) for seconds since 1970-01-01:00:00:00, so it
> > will overflow at 2038-01-19 03:14:08 on 32-bit systems. We call this "2038 safety" issue.
>
> We really know that by now. No need to repeat that for every patch.
>
> > As part of addressing 2038 saftey for in-kernel uses, this patch creates no functional change
> > in existing users, and converts rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys().
>
> Please line break your changelogs properly. That's how it should look
> like:
>
> > As part of addressing 2038 saftey for in-kernel uses, this patch
> > creates no functional change in existing users, and converts
> > rtc_tm_to_time_unsafe() to rtc_tm_to_time() in rtc_hctosys().
>
> Can you spot the difference?
>
> > @@ -26,9 +26,10 @@ static int __init rtc_hctosys(void)
> > {
> > int err = -ENODEV;
> > struct rtc_time tm;
> > - struct timespec tv = {
> > + struct timespec64 tv = {
> > .tv_nsec = NSEC_PER_SEC >> 1,
> > };
> > + struct timespec ts32;
>
> So this is exactly why I dislike this whole flag day conversion
> thing. If you add
>
> rtc_tm_to_time64()
> do_settimeofday64()
>
> in the first place, you can convert the whole function in one go
> without introducing intermediate variables which then need to be
> undone later again.

Aside of that ts32 is a complete misnomer because on 64 bit struct
timespec already has a 64bit seconds representation.

Thanks,

tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/