Re: [PATCH 2/2] PM / Domains: Extract code to power off/on a PM domain

From: Kevin Hilman
Date: Wed Oct 29 2014 - 13:10:07 EST


Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> writes:

> Hi Ulf,
>
> On Wed, Oct 29, 2014 at 2:25 PM, Ulf Hansson <ulf.hansson@xxxxxxxxxx> wrote:
>> On 23 October 2014 14:12, Geert Uytterhoeven <geert+renesas@xxxxxxxxx> wrote:
>>> PM domains are powered on/off from various places. Some callers do
>>> latency measurements, others don't. Consolidate using two helper
>>> functions, which always measure the latencies, and update the stored
>>> latencies when needed.
>>>
>>> Other minor changes:
>>> - Use pr_warn() instead of pr_warning(),
>>> - There's no need to check genpd->name, %s handles NULL pointers fine,
>>> - Make the warning format strings identical, to save memory.
>>>
>>> Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
>>
>> Reviewed-by: Ulf Hansson <ulf.hansson@xxxxxxxxxx>
>
> Thanks for your review.
>
>>> --- a/drivers/base/power/domain.c
>>> +++ b/drivers/base/power/domain.c
>>> @@ -151,6 +151,59 @@ static void genpd_recalc_cpu_exit_latency(struct generic_pm_domain *genpd)
>>> genpd->cpuidle_data->idle_state->exit_latency = usecs64;
>>> }
>>>
>>> +static int do_genpd_power_on(struct generic_pm_domain *genpd)
>>
>> Should we try to agree on the prefixes of the function names in genpd?
>> Currently there are a mix of them.
>>
>> May I suggest we try to stick to this:
>>
>> Exported functions:
>> pm_genpd_*
>> _pm_genpd_*
>> __pm_genpd_*
>>
>> Static functions:
>> genpd_*
>> _genpd_*
>> __genpd_*
>>
>> What do you think? Do you have any better suggestions?
>
> Sounds sane.
>
> So:
>
> s/do_genpd_power_on/genpd_power_on/
> s/do_genpd_power_off/genpd_power_off/

With that name change, feel free to add

Reviewed-by: Kevin Hilman <khilman@xxxxxxxxxx>

Kevin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/