Re: [PATCH V2 06/15] genirq: Generic chip: Optimize for fixed-endian systems

From: Arnd Bergmann
Date: Thu Oct 30 2014 - 05:04:47 EST


On Wednesday 29 October 2014 21:16:58 Brian Norris wrote:
> > static int is_big_endian(struct irq_chip_generic *gc)
> > {
> > - return !!(gc->domain->gc->gc_flags & IRQ_GC_BE_IO);
> > + if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP) &&
> > + !IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE))
> > + return 0;
> > + else if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE) &&
> > + !IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP))
> > + return 1;
>
> Would XOR make this any easier to read? e.g.:
>
> if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP) ^
> IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE))
> return IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE);
> else
> ...
>

I think that would only be easier to read for the compiler, not for
for a human. ;-)

Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/