Re: [RFC v2 1/4] backports: replace CPTCFG prefix for CONFIG_BACKPORT

From: Luis R. Rodriguez
Date: Mon Nov 03 2014 - 14:57:13 EST


On Mon, Nov 3, 2014 at 11:40 AM, Johannes Berg
<johannes@xxxxxxxxxxxxxxxx> wrote:
> On Mon, 2014-11-03 at 11:30 -0800, Luis R. Rodriguez wrote:
>> On Fri, Oct 31, 2014 at 1:33 PM, Luis R. Rodriguez <mcgrof@xxxxxxxx> wrote:
>> >> That also makes me think of something else - we currently use BACKPORT_
>> >> as a prefix for some of the other stuff under compat/Kconfig, and in
>> >> fact rename some things (like CONFIG_BACKPORT_AVERAGE) so maybe also
>> >> using CONFIG_BACKPORT_ here isn't a great idea? Might want to use
>> >> something else, say CONFIG_BPT_ or so.
>> >
>> > That's a good point, I take it that it does not matter which one we
>> > pick for each, so long as its different? If so I think CONFIG_BACKPORT
>> > is pretty clear for things we carry over like device drivers, but this
>> > is just subjective and so long as we pick something I think it'll be
>> > fine.
>>
>> Thought about this some more, the stuff under compat/ is just
>> backported through a slightly different strategy -- the Kconfig
>> copy-file stuff but yet its very similar to the copy-list mechanism,
>> where it ends up is different but I am not sure if it makes sense to
>> keep a different naming scheme for each backport strategy.
>
> Yes, but the stuff under compat/ is also treated specially by the
> scripting - config symbols there automatically replace the ones in the
> rest of the tree for example (see "config AVERAGE" for example, you get
> "depends on BACKPORT_AVERAGE" and some BUILD_PACKPORT_AVERAGE magic)

With my current code I end up with on a package (not integration):

config BACKPORT_BUILD_AVERAGE
bool
depends on !AVERAGE
default y if BACKPORT_USERSEL_BUILD_ALL
default y if BACKPORT_AVERAGE
#h-file linux/average.h
#c-file lib/average.c

config BACKPORT_AVERAGE
bool


I do see I on the package with this on the Makfile though:


compat-$(CONFIG_BACKPORT_BACKPORT_BUILD_AVERAGE) += lib-average.o

Would it not suffice to just ensure we don't have BACKPORT_BACKPORT_
here and just BACKPORT_ once ?

Luis
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/