Re: [PATCH v5 1/3] mtd: nand: gpmi: add gpmi_move_bits function

From: Huang Shijie
Date: Sun Nov 30 2014 - 10:40:30 EST


On Sun, Nov 30, 2014 at 09:55:00AM +0100, Boris Brezillon wrote:
> Hi Brian,
>
> On Sun, 30 Nov 2014 00:11:10 -0800
> Brian Norris <computersforpeace@xxxxxxxxx> wrote:
>
> > On Wed, Nov 26, 2014 at 05:57:08PM +0100, Boris Brezillon wrote:
> > > On Wed, 26 Nov 2014 17:53:11 +0100 Boris Brezillon <boris.brezillon@xxxxxxxxxxxxxxxxxx> wrote:
> > > > +/**
> > > > + * gpmi_move_bits - move bits from one memory region to another
> > > > + * @dst: destination buffer
> > > > + * @dst_bit_off: bit offset we're starting to write at
> > > > + * @src: source buffer
> > > > + * @src_bit_off: bit offset we're starting to read from
> > > > + * @nbits: number of bits to copy
> > > > + *
> > > > + * This functions copies bits from one memory region to another, and is used by
> > > > + * the GPMI driver to copy ECC sections which are not guaranteed to be byte
> > > > + * aligned.
> > >
> > > I forgot to add that src and dst should not overlap, otherwise it won't
> > > work...
> >
> > Hmm, normally that's implied for copy-like operations. But since you
> > named this function "move" (rather than "copy" or "cpy"), that's a
> > little less clear.
>
> Indeed, that's a good point.
>
> >
> > Did you have a good reason for the "move" name? If not, maybe it's worth
> > changing.
>
> No, I don't, and I'd prefer changing the name than implementing a non
> destructive move function.
>
> I'll send a new version with this change.
Please add my tested-by.

Tested-by: Huang Shijie <shijie8@xxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/