Re: [PATCH 2/5] gpio: Cygnus: add GPIO driver

From: Ray Jui
Date: Sun Dec 07 2014 - 20:34:29 EST




On 12/5/2014 8:24 PM, Joe Perches wrote:
On Fri, 2014-12-05 at 19:41 -0800, Ray Jui wrote:
On 12/5/2014 6:34 PM, Joe Perches wrote:
On Fri, 2014-12-05 at 18:14 -0800, Ray Jui wrote:
On 12/5/2014 5:28 PM, Joe Perches wrote:
On Fri, 2014-12-05 at 16:40 -0800, Ray Jui wrote:
+ for_each_set_bit(bit, &val, 32) {
[]
Actually, by reviewing the code more deeply, I'm not sure why using
for_each_set_bit here is 'endian unsafe'.

It's not. The 32 confused me as it was long
and sizeof(long) isn't necessarily 32.

Maybe the 32 should be a #define



Okay, to improve readability, I will change 32 to NGPIOS_PER_BANK.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/