Re: [PATCH v18 12/12] drm: bridge/dw_hdmi: add rockchip rk3288 support
From: Heiko Stübner
Date: Thu Dec 11 2014 - 06:25:03 EST
Am Mittwoch, 10. Dezember 2014, 20:36:17 schrieb Daniel Kurtz:
> This driver adds HDMI to rockchip/drm. The fact that rockchip's hdmi
> uses dw_hdmi is an implementation detail. I do not think that the names
> used for rk3288-hdmi should include "dw" in them.
> See inline for what I mean...
I guess in general this is more a matter of preference.
Past practices suggest that having the dw in the name is a sane solution too,
like in dw_mmc-foo (mmc/host), dwmac-foo (net/ethernet/stmicro/stmmac).
And personally I'd keep to this already established naming scheme ... i.e. not
hiding the dw heritage.
And also it looks like other involved parties like Philipp and Russell seemed
to be ok with the naming through the revisions till now.
> > +static enum drm_mode_status
> > +dw_hdmi_rockchip_mode_valid(struct drm_connector *connector,
> Similarly, I would rename these function names to start with
> rockchip_hdmi (or maybe rk_hdmi for brevity).
> Especially the ones for the module & driver: (bind/unbind/probe/remove).
Please keep to one rk <-> rockchip style at least per subsystem. The core drm
driver uses rockchip, so the hdmi driver should too (instead of rk).
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/