Re: [PATCH v5 0/6] mmc: rtsx: add support for sdio card

From: Ulf Hansson
Date: Tue Dec 23 2014 - 10:33:13 EST


On 23 December 2014 at 02:19, <micky_ching@xxxxxxxxxxxxxx> wrote:
> From: Micky Ching <micky_ching@xxxxxxxxxxxxxx>
>
> v5:
> fix patch(5) building error, no code change diff v4.
>
> v4:
> split patch in more detailed patches. no code changes diff v3.
>
> v3:
> rtsx_pci_sdmmc.c:
> - dump_reg_range
> - remove unused pointer check
> - fix start index
> v2:
> rtsx_pci.h:
> - remove unused rtsx_pci_write_le32
> - add SD_CMD_START
> rtsx_pci_sdmmc.c:
> - dump_reg_range
> - alloc data on stack
> - remove forward declaration
> - use SD_CMD_START replace magic number 0x40
> - move initialize assignment to error handling
>
> This patch is used to change transfer mode for sdio card support
> by SD interface.
>
> Micky Ching (6):
> mfd: rtsx: add func to split u32 into register
> mmc: rtsx: add dump_reg_range to simplify dump register
> mmc: rtsx: init cookie at probe/card_event
> mmc: rtsx: add helper function to simplify code
> mmc: rtsx: add support for sdio card
> mmc: rtsx: swap function position to avoid pre declaration
>
> drivers/mmc/host/rtsx_pci_sdmmc.c | 522 +++++++++++++++++++++-----------------
> include/linux/mfd/rtsx_pci.h | 9 +
> 2 files changed, 296 insertions(+), 235 deletions(-)

Thanks! Re-applied for next.

Kind regards
Uffe

>
> --
> 1.9.1
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/